PSILO®: A Protein Structure Database System

System Requirements

PSILO is a sophisticated database system that works with a number of third-party software applications, all of which must be installed and configured before installing PSILO.

The following lists the server hardware and software requirements for PSILO:

Supported Description
Operating Systems
  • Linux with GNU C Library (glibc) 2.5 or above and glibc++ 3.4 or newer (corresponding to CentOS/RHEL 5, Fedora Core 6, SLES 11, Ubuntu 7.04, Mint 3.0)
  • Mac OS X 10.6, 10.7, 10.8, 10.9
Notes
  • UNIX server, minimum dual 2GHz multi-core CPU
  • 2 GB system memory per CPU core
  • 1 TB disk space (100 GB without the database)
  • Network connectivity
  • Internet FTP access to receive PDB updates from RCSB (or a local mirror)
  • Operating system version numbers are the suggested minimum versions
Database Products
  • MySQL 5.5.31 or higher (included in the PSILO package), or
  • Oracle 11g Release 1 or higher with Oracle Text
Web Server Products
  • Web Server - Apache 2.4.3 or any other modern web server able to serve PHP 5 documents (included in the PSILO package)
  • PHP 5.4.11 or higher (included in the PSILO package)
MOE and other components
  • MOE/web
  • PERL 5.x or higher
  • Sun Java Virtual Machine 1.5 or higher
  • Sendmail, or equivalent - the server must be able to send e-mail to all users